Hotel bookings
Incident Report for Skiddle
Resolved
This incident has been resolved.
Posted almost 3 years ago. Mar 12, 2015 - 15:12 UTC
Monitoring
We're experiencing some issues with our hotel bookings partner, which is causing delays and sometime errors when checking hotel availability and making bookings.

This is being resolved by our bookings partner and should be fully operational shortly.
Posted almost 3 years ago. Mar 12, 2015 - 13:22 UTC