Promotion Centre unavailable
Incident Report for Skiddle
Resolved
All issues have been resolved and the Promotion Centre is now available.
Posted about 1 year ago. May 05, 2016 - 20:42 UTC
Investigating
The promotion centre is currently unavailable. We're working to fix this issue and will post updates shortly. This does not affect ticket sales or the RapidScan app.
Posted about 1 year ago. May 05, 2016 - 20:23 UTC