Server Issues
Incident Report for Skiddle
Resolved
This is has now been resolved
Posted 9 months ago. Sep 22, 2016 - 13:35 UTC
Investigating
We are currently experiencing issues with our servers, service will resume as soon as possible
Posted 9 months ago. Sep 22, 2016 - 13:12 UTC