We're experiencing some slow response times on our website
Incident Report for Skiddle
Resolved
This incident has been resolved.
Posted Mar 26, 2021 - 16:25 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2021 - 16:12 GMT
Investigating
We're currently investigating the cause and will update shortly
Posted Mar 26, 2021 - 16:05 GMT
This incident affected: Skiddle Website.