Phone lines and email support
Incident Report for Skiddle
Resolved
This incident has been resolved.
Posted Mar 05, 2020 - 20:21 GMT
Monitoring
The planned electrical work being performed in our area took longer than expected, so our office was without power until 17:00. As such, phones and email support were unavailable or limited.

We now have power and will be working through any support tickets logged today. Thanks for your patience.
Posted Mar 05, 2020 - 17:05 GMT
This incident affected: Phone lines and email support.